#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(.*?): (.*)"
Local $sString = "Matthäuspassion, SWV 479: Introitus:Test" & @CRLF & _
"Matthäuspassion, SWV 479:Introitus:Test" & @CRLF & _
"letztlich" & @CRLF & _
"Matthäuspassion, SWV 479: Introitus - Test" & @CRLF & _
"" & @CRLF & _
"Erster Text, zweiter Text : Dritter Text" & @CRLF & _
"Vierter Text, fünfter Text : Sechster Text" & @CRLF & _
"Siebter Text, achter Text : Neunter Text"
Local $sSubst = "$1 xxx $2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)