use strict;
my $str = 'Matthäuspassion, SWV 479: Introitus:Test
Matthäuspassion, SWV 479:Introitus:Test
letztlich
Matthäuspassion, SWV 479: Introitus - Test
Erster Text, zweiter Text : Dritter Text
Vierter Text, fünfter Text : Sechster Text
Siebter Text, achter Text : Neunter Text';
my $regex = qr/(.*?): (.*)/mp;
my $subst = '$1 xxx $2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";