// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(.*?): (.*)").unwrap();
let string = "Matthäuspassion, SWV 479: Introitus:Test
Matthäuspassion, SWV 479:Introitus:Test
letztlich
Matthäuspassion, SWV 479: Introitus - Test
Erster Text, zweiter Text : Dritter Text
Vierter Text, fünfter Text : Sechster Text
Siebter Text, achter Text : Neunter Text";
let substitution = "$1 xxx $2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}