#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([1-9]|[1-5][0-9]|6[0-3])-([1-5][0-9]|6[0-4]|[2-9])"
Local $sString = "32-1" & @CRLF & _
"32-2" & @CRLF & _
"1-2" & @CRLF & _
"63-10" & @CRLF & _
"32-64"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")