import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[\\d+\\]\\s(\\w+)\\s\\|\\s(\\w+)\\s\\|\\s(\\w+)\\s\\|\\s(\\S+)\\s(\\S+)\\s\\|\\s(\\S+)\\s(\\S+)\\s\\|\\s(\\S+)\\s(\\S+)";
final String string = "[1] weight | width | depth | 5.0 cm | 6.0 mm^2 | 10.12 cm^3";
final String subst = "name = $1\\nvalue = $4\\nunit = $5\\n\\nname = $2\\nvalue = $6\\nunit = $7\\n\\nname = $3\\nvalue = $8\\nunit = $9";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}