# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\[\d+\]\s(\w+)\s\|\s(\w+)\s\|\s(\w+)\s\|\s(\S+)\s(\S+)\s\|\s(\S+)\s(\S+)\s\|\s(\S+)\s(\S+)"
test_str = "[1] weight | width | depth | 5.0 cm | 6.0 mm^2 | 10.12 cm^3"
subst = "name = $1\\nvalue = $4\\nunit = $5\\n\\nname = $2\\nvalue = $6\\nunit = $7\\n\\nname = $3\\nvalue = $8\\nunit = $9"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.