re = /\[\d+\]\s(\w+)\s\|\s(\w+)\s\|\s(\w+)\s\|\s(\S+)\s(\S+)\s\|\s(\S+)\s(\S+)\s\|\s(\S+)\s(\S+)/m
str = '[1] weight | width | depth | 5.0 cm | 6.0 mm^2 | 10.12 cm^3'
subst = 'name = $1\\nvalue = $4\\nunit = $5\\n\\nname = $2\\nvalue = $6\\nunit = $7\\n\\nname = $3\\nvalue = $8\\nunit = $9'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result