re = /^[a-zA-z.0-9]{1,50}@(gmail|outlook|hotmail|zoho|yahoo|)\.com$/m
str = 'sahilxresta98@gmail.com
literarl@outlook.com
sneha@yahoo.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end