$re = '/^([0-9]{4,4})[-]([0-9]{2,2})$/';
$str = '2012-08';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);