re = /(?!e\d)[a-z](?<!\\[a-z])/m
str = 'azjf8ee7Ldoge \\n Hmeqze= AZ12D Fs \\nsdfz14eZe148r.'
subst = '\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result