package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[\d\.]+`)
var str = `12.3.4.1.234
12f.3.4.1.234
sdgdfg
sdgsdg11
11dcghdfh`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}