$re = '/\bM[rs]\.(?: (?!M[rs]\.|and )\w+)*/m';
$str = 'Mr. Snow
Mr. John Snow
Mr. John Snow (Winterfall of the nord lands)
Mr. Snow and Ms. Stark
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);