using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[-+]?([0-9]*(\.[0-9]*)?[a-z]+)+$";
string input = @"30s
5m
5m30s
3m3m
3s3m
3m3m3m
0
m
s
1
2
3h
3h0s
3h0m
a
123aa456aaa13aaa
45aa
54
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}