import re
regex = re.compile(r"^[-+]?([0-9]*(\.[0-9]*)?[a-z]+)+$", flags=re.MULTILINE)
test_str = ("30s\n"
"5m\n"
"5m30s\n"
"3m3m\n"
"3s3m\n"
"3m3m3m\n"
"0\n"
"m\n"
"s\n"
"1\n"
"2\n"
"3h\n"
"3h0s\n"
"3h0m\n"
"a\n"
"123aa456aaa13aaa\n"
"45aa\n"
"54\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")