re = /^[-+]?([0-9]*(\.[0-9]*)?[a-z]+)+$/m
str = '30s
5m
5m30s
3m3m
3s3m
3m3m3m
0
m
s
1
2
3h
3h0s
3h0m
a
123aa456aaa13aaa
45aa
54
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end