using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^https?:\/\/www\.mangeznotez(dev)?\.com\/booking\/[a-z\d]+\/\d\?giftCardCode=[a-zA-Z\d]{5}";
string input = @"https://www.mangeznotezdev.com/booking/363acccf265c890fd0134c771ee146b1/1?giftCardCode=f2c63";
RegexOptions options = RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}