package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?i)--.*|/\*(?s).*?\*/`)
var str = `/* bllalal
dfmkdmfd
dfdsfsd */
/*lllll*/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}