#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ix)(?:^|(?<=\s)) # delimitador inicial" & @CRLF & _
"[+-]?(?:\d+\.\d+|\d+\.|\.\d+|\d+) # valores con o sin signo" & @CRLF & _
"(?:e[+-]?\d+)? # parte exponencial" & @CRLF & _
"(?=\s) # delimitador final"
Local $sString = "Hace coincidir para el sistema de numeración decimal valores numéricos aislados, es decir, valores no unidos a otros caracteres." & @CRLF & _
"test: 11 +11 -11 99-99 a99 a+99 a-99 99a +99a -99a" & @CRLF & _
"22e22 22e+22 +22e22 +22e+22" & @CRLF & _
"22.22 22. .22" & @CRLF & _
"22.e22 22.e+22 22.22e22 22.22e+22 .22e22 .22e+22" & @CRLF & _
"88e 88e+ e88 e+88 88e88."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")