$re = '/(?:^|(?<=\s)) # delimitador inicial
[+-]?(?:\d+\.\d+|\d+\.|\.\d+|\d+) # valores con o sin signo
(?:e[+-]?\d+)? # parte exponencial
(?=\s) # delimitador final/ix';
$str = 'Hace coincidir para el sistema de numeración decimal valores numéricos aislados, es decir, valores no unidos a otros caracteres.
test: 11 +11 -11 99-99 a99 a+99 a-99 99a +99a -99a
22e22 22e+22 +22e22 +22e+22
22.22 22. .22
22.e22 22.e+22 22.22e22 22.22e+22 .22e22 .22e+22
88e 88e+ e88 e+88 88e88.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);