#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<p(?:(?!<|>).)*>((?:(?!<p|<\/p>).|\s)*)<\/p>"
Local $sString = "</span></p>" & @CRLF & _
"" & @CRLF & _
"<p style="text-align: justify;"><span style="font-size: 14px;"> Tên công ty: {company_name}" & @CRLF & _
"</span></p>" & @CRLF & _
"" & @CRLF & _
"<p style="text-align: justify;"><span style="font-size: 14px;"> (#)Địa chỉ: {company_address}</span></p>" & @CRLF & _
"" & @CRLF & _
"<p style="text-align: justify;"> (#)<span style="font-size: 14px;">{company_branch}</span></p>" & @CRLF & _
"" & @CRLF & _
"<p style="text-align: justify;"><span style="font-size: 14px;"> </span> (#)<span style="font-size: 14px;">{company_email}</span></p>" & @CRLF & _
"" & @CRLF & _
"<p style="text-align: justify;"><span style="font-size: 14px;"> </span> (#)<span style="font-size: 14px;">{company_phone1}</span></p>" & @CRLF & _
"" & @CRLF & _
"<p style="text-align: justify;"><span style="font-size: 14px;"> </span> (#)<span style="font-size: 14px;">{company_website}</span></p>" & @CRLF & _
"" & @CRLF & _
"<p style="text-align: justify;"><span style="font-size: 14px;"> {company_tax_code}</span></p>" & @CRLF & _
"" & @CRLF & _
"<p style="text-align: justify;"><span style="font-size: 14px;">"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")