import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<p(?:(?!<|>).)*>((?:(?!<p|<\\/p>).|\\s)*)<\\/p>";
final String string = "</span></p>\n\n"
+ "<p style=\"text-align: justify;\"><span style=\"font-size: 14px;\"> Tên công ty: {company_name}\n"
+ "</span></p>\n\n"
+ "<p style=\"text-align: justify;\"><span style=\"font-size: 14px;\"> (#)Địa chỉ: {company_address}</span></p>\n\n"
+ "<p style=\"text-align: justify;\"> (#)<span style=\"font-size: 14px;\">{company_branch}</span></p>\n\n"
+ "<p style=\"text-align: justify;\"><span style=\"font-size: 14px;\"> </span> (#)<span style=\"font-size: 14px;\">{company_email}</span></p>\n\n"
+ "<p style=\"text-align: justify;\"><span style=\"font-size: 14px;\"> </span> (#)<span style=\"font-size: 14px;\">{company_phone1}</span></p>\n\n"
+ "<p style=\"text-align: justify;\"><span style=\"font-size: 14px;\"> </span> (#)<span style=\"font-size: 14px;\">{company_website}</span></p>\n\n"
+ "<p style=\"text-align: justify;\"><span style=\"font-size: 14px;\"> {company_tax_code}</span></p>\n\n"
+ "<p style=\"text-align: justify;\"><span style=\"font-size: 14px;\">";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}