const regex = /(\d+)\s{2,}([.a-zA-Z,'À-úÀ-ÿ()?\-\/\d]+(?:\s?[.a-zA-Z,'À-úÀ-ÿ()?\-\/\d])*)(?|\s{2,}((?:[.a-zA-Z,'À-úÀ-ÿ()?\-\/\d]+(?:\s?[.a-zA-Z,'À-úÀ-ÿ()?\-\/\d])*))|())\s{2,}(I|PF|MA)\s{2,}(I|PF|PL|LI|MA|CV|MJ)\s{2,}(\w+)\s{2,}(\d+,\d{4})/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d+)\\s{2,}([.a-zA-Z,\'À-úÀ-ÿ()?\\-\\\/\\d]+(?:\\s?[.a-zA-Z,\'À-úÀ-ÿ()?\\-\\\/\\d])*)(?|\\s{2,}((?:[.a-zA-Z,\'À-úÀ-ÿ()?\\-\\\/\\d]+(?:\\s?[.a-zA-Z,\'À-úÀ-ÿ()?\\-\\\/\\d])*))|())\\s{2,}(I|PF|MA)\\s{2,}(I|PF|PL|LI|MA|CV|MJ)\\s{2,}(\\w+)\\s{2,}(\\d+,\\d{4})', 'g')
const str = `\`2236 ARGEMIRO PATROCINIO ARGEMIRO I I UBC 3,8462
1150721 ZACHARY F CONDON ZACH CONDON I I FINTAGE 8,3333
50300 COMERCIAL FONOGRAFICA RGE LTDA. PF LI ABRAMUS 25,0000\`
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}