#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:na|(?:t|s|k|x)(?:a|(?:i|e|u|o)(?:n|(?:t|s|k|x)(?:a|(?:i|e|u|o)))))"
Local $sString = "n" & @CRLF & _
"na" & @CRLF & _
"sa" & @CRLF & _
"xa" & @CRLF & _
"" & @CRLF & _
"ti" & @CRLF & _
"tin" & @CRLF & _
"ten" & @CRLF & _
"tun" & @CRLF & _
"ton" & @CRLF & _
"tan" & @CRLF & _
"" & @CRLF & _
"kis" & @CRLF & _
"kisa" & @CRLF & _
"kise"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")