using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:na|(?:t|s|k|x)(?:a|(?:i|e|u|o)(?:n|(?:t|s|k|x)(?:a|(?:i|e|u|o)))))";
string input = @"n
na
sa
xa
ti
tin
ten
tun
ton
tan
kis
kisa
kise";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}