re = /(?:na|(?:t|s|k|x)(?:a|(?:i|e|u|o)(?:n|(?:t|s|k|x)(?:a|(?:i|e|u|o)))))/m
str = 'n
na
sa
xa
ti
tin
ten
tun
ton
tan
kis
kisa
kise'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end