#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^GRP-[0-9]+\s(FIX|CHANGE|HOTFIX|FEATURE)\s(CORE|SHARED|ADM|CSR|BUS|OTHER)\s-\s(?=[^a-zA-Z0-9\n]*[a-zA-Z0-9])(?:\([^()\n]*\)\s:\s)?[^()\n]*$"
Local $sString = "GRP-0888 FIX OTHER - (jest.config.js) : Fix testMatch option issue" & @CRLF & _
"GRP-0888 FIX OTHER - Fix testMatch option issue" & @CRLF & _
"GRP-0988 FIX CORE - (Some change)" & @CRLF & _
"GRP-0988 FIX CORE - (Some change) - Some description" & @CRLF & _
"GRP-0988 FIX CORE - (" & @CRLF & _
"GRP-0988 FIX CORE - ()" & @CRLF & _
"GRP-0988 FIX CORE - (Some change" & @CRLF & _
"GRP-0988 FIX CORE - Some change)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")