using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^GRP-[0-9]+\s(FIX|CHANGE|HOTFIX|FEATURE)\s(CORE|SHARED|ADM|CSR|BUS|OTHER)\s-\s(?=[^a-zA-Z0-9\n]*[a-zA-Z0-9])(?:\([^()\n]*\)\s:\s)?[^()\n]*$";
string input = @"GRP-0888 FIX OTHER - (jest.config.js) : Fix testMatch option issue
GRP-0888 FIX OTHER - Fix testMatch option issue
GRP-0988 FIX CORE - (Some change)
GRP-0988 FIX CORE - (Some change) - Some description
GRP-0988 FIX CORE - (
GRP-0988 FIX CORE - ()
GRP-0988 FIX CORE - (Some change
GRP-0988 FIX CORE - Some change)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}