const regex = /EDT\s\d*\s(?<USERNAME>[^\s]+)\s*(?<STATUS>\w+( & \w+)?)\s*(?<EXPIRY>\d+-[A-Z]+-\d+)?\s*(?<ROLE>[A-Za-z0-9_-]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('EDT\\s\\d*\\s(?<USERNAME>[^\\s]+)\\s*(?<STATUS>\\w+( & \\w+)?)\\s*(?<EXPIRY>\\d+-[A-Z]+-\\d+)?\\s*(?<ROLE>[A-Za-z0-9_-]+)', 'gm')
const str = `Thu Sep 5 10:00:02 EDT 2019 XDB EXPIRED & LOCKED 28-SEP-11 CTXAPP
Thu Sep 5 10:00:02 EDT 2019 VWEinsnte3345 LOCKED GPW_READ`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}