using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"The (?:(?!no|never|not).){0,50}? has not fully complied with its obligations under the Prior Undertaking";
string input = @"The City has not fully complied with its obligations under the Prior Undertaking
The School District has not fully complied with its obligations under the Prior Undertaking
The District has not fully complied with its obligations under the Prior Undertaking
The not District has not fully complied with its obligations under the Prior Undertaking";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}