package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\[monitor[^\]]+\][^\[]?)(ignoreOlderThan\s?=\s?[0-9]+\w)([^\[]+?ignoreOlderThan\s?=\s?[0-9]+\w)([^\[]+)?`)
var str = `[default]host = 10.2.2.15[monitor://apath]ignoreOlderThan = 14dindex=testsourcetype=whateverignoreOlderThan = 30d[monitor://truck]ignoreOlderThan = 14d`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}