import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\[monitor[^\\]]+\\][^\\[]?)(ignoreOlderThan\\s?=\\s?[0-9]+\\w)([^\\[]+?ignoreOlderThan\\s?=\\s?[0-9]+\\w)([^\\[]+)?";
final String string = "[default]host = 10.2.2.15[monitor://apath]ignoreOlderThan = 14dindex=testsourcetype=whateverignoreOlderThan = 30d[monitor://truck]ignoreOlderThan = 14d";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}