# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(<number>[^\S\n]*){2,}/\1/gm;t' <<< "<number><number>
<number> <number>
not <number> test <number>
<number> <number> test
<number> <number> <number><number><number> <number> "