# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(<number>[^\S\n]*){2,}"
test_str = ("<number><number>\n"
"<number> <number>\n"
"not <number> test <number>\n"
" <number> <number> test\n"
"<number> <number> <number><number><number> <number> ")
subst = "\\1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.