package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([\s\n]*(^\s*)[^{};]*\{)`)
var str = `
public class Main {
class innerClass {
int a;
int b;
@Override
private int goo() {
}
}
String a;
public static void main (String[] args) {
// blablabla
}
@Override
public int foo(int a) {
}
}`
var substitution = "$2/***/$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}