use strict;
my $str = '
public class Main {
class innerClass {
int a;
int b;
@Override
private int goo() {
}
}
String a;
public static void main (String[] args) {
// blablabla
}
@Override
public int foo(int a) {
}
}';
my $regex = qr/^([\s\n]*(^\s*)[^{};]*\{)/mp;
my $subst = '$2/***/$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";