# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^([\s\n]*(^\s*)[^{};]*\{)"
test_str = ("\n"
"public class Main {\n\n"
" class innerClass {\n\n"
" int a;\n"
" int b;\n\n"
" @Override\n"
" private int goo() {\n\n"
" }\n"
" }\n\n"
" String a;\n\n"
" public static void main (String[] args) {\n"
" // blablabla\n"
" }\n\n"
" @Override\n"
" public int foo(int a) {\n\n"
" }\n"
"}")
subst = "$2/***/$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.