#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\[(.*?)\]"
Local $sString = ""The quick, brown fox jumps over a lazy dog. DJs flock by when MTV ax quiz prog. " & @CRLF & _
"Junk MTV quiz graced by fox whelps. [Never gonna ] Bawds jog, flick quartz, vex nymphs. " & @CRLF & _
"[give you up\n] Waltz, bad nymph, for quick jigs vex! Fox nymphs grab quick-jived waltz. " & @CRLF & _
"Brick quiz whangs jumpy veldt fox. [Never ] Bright vixens jump; [gonna let ] dozy fowl " & @CRLF & _
"quack. Quick wafting zephyrs vex bold Jim. Quick zephyrs blow, vexing daft Jim. Charged " & @CRLF & _
"[you down\n] fop blew my junk TV quiz. How quickly daft jumping zebras vex. Two driven " & @CRLF & _
"jocks help fax my big quiz. Quick, Baz, get my woven flax jodhpurs! "Now fax quiz Jack!" " & @CRLF & _
"my brave ghost pled. [Never ] Five quacking zephyrs jolt my wax bed. [gonna ] Flummoxed " & @CRLF & _
"by job, kvetching W. zaps Iraq. Cozy sphinx waves quart jug of bad milk. [run around ] " & @CRLF & _
"A very bad quack might jinx zippy fowls. Few quips galvanized the mock jury box. Quick " & @CRLF & _
"brown dogs jump over the lazy fox. The jay, pig, fox, zebra, and my wolves quack! " & @CRLF & _
"[and desert you] Blowzy red vixens fight for a quick jump. Joaquin Phoenix was gazed " & @CRLF & _
"by MTV for luck. A wizard’s job is to vex chumps quickly in fog. Watch "Jeopardy!", " & @CRLF & _
"Alex Trebek's fun TV quiz game.""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")