// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[1-9][0-9]*(?:\.[0-9]+)?\$?$").unwrap();
let string = "t1est
230.01
foo
bar
304958$
bar
534534$23";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}