re = /\d{3}(\.)?\d{3}\1\d{3}-\d+/m
str = 'CPFs:
- 345.679.411-64
- 555.984.452-33'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end