package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?<s1>\d)(?<n>[^~]*)(~(?<a1>\d*)?(~(?<s2>\d)~(?<a2>.+))?)?$`)
var str = `142у~72~3~Г7
0~~1~1
542У~~1~2
142~1
142
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}