import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<s1>\\d)(?<n>[^~]*)(~(?<a1>\\d*)?(~(?<s2>\\d)~(?<a2>.+))?)?$";
final String string = "142у~72~3~Г7\n"
+ "0~~1~1\n"
+ "542У~~1~2\n"
+ "142~1\n"
+ "142\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}