const regex = /^(?<s1>\d)(?<n>[^~]*)(~(?<a1>\d*)?(~(?<s2>\d)~(?<a2>.+))?)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?<s1>\\d)(?<n>[^~]*)(~(?<a1>\\d*)?(~(?<s2>\\d)~(?<a2>.+))?)?$', 'gm')
const str = `142у~72~3~Г7
0~~1~1
542У~~1~2
142~1
142
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}