Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
^(?<s1>\d)(?<n>[^~]*)(~(?<a1>\d*)?(~(?<s2>\d)~(?<a2>.+))?)?$
/
gm
Input 1
1
New
142у~72~3~Г7 0~~1~1 542У~~1~2 142~1 142