// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?<s1>\d)(?<n>[^~]*)(~(?<a1>\d*)?(~(?<s2>\d)~(?<a2>.+))?)?$").unwrap();
let string = "142у~72~3~Г7
0~~1~1
542У~~1~2
142~1
142
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}