$re = '/^(\+375|80) \((29|25|44|33|17)\) [0-9]{3}-[0-9]{2}-[0-9]{2}$/m';
$str = '+375 (33) 999-99-99';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);