#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)<block.*?Name[\s|\t]+data3[\s|\t]+.*?<\/block>"
Local $sString = "<block>" & @CRLF & _
"Name data1" & @CRLF & _
"Spec 36" & @CRLF & _
"</block>" & @CRLF & _
"<block>" & @CRLF & _
"Name data2" & @CRLF & _
"Spec 22" & @CRLF & _
"</block>" & @CRLF & _
"<block>" & @CRLF & _
"Name data3" & @CRLF & _
"Spec 56" & @CRLF & _
"</block>" & @CRLF & _
"<block>" & @CRLF & _
"Name data4" & @CRLF & _
"Spec 41" & @CRLF & _
"</block>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")