use strict;
my $str = '<block>
Name data1
Spec 36
</block>
<block>
Name data2
Spec 22
</block>
<block>
Name data3
Spec 56
</block>
<block>
Name data4
Spec 41
</block>';
my $regex = qr/<block.*?Name[\s|\t]+data3[\s|\t]+.*?<\/block>/msp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}