// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?ms)<block.*?Name[\s|\t]+data3[\s|\t]+.*?<\/block>").unwrap();
let string = "<block>
Name data1
Spec 36
</block>
<block>
Name data2
Spec 22
</block>
<block>
Name data3
Spec 56
</block>
<block>
Name data4
Spec 41
</block>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}