import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!^\\s)(?<=[\\((\\,\\s?)])(FoX::)?Image\\s?\\*";
final String string = ", Image *\n"
+ ",Image *\n"
+ "(Image *\n"
+ "( Image *\n"
+ ", FoX::Image *\n"
+ ",FoX::Image *\n"
+ "(FoX::Image *\n"
+ "( FoX::Image *\n"
+ "/* [retval][out] */ ICscImage **pVal) = 0;\n"
+ " Image* pImage = Image::Create();\n"
+ " Image* pImage = Image::Create();";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}