const regex = /(?<!^\s)(?<=[\((\,\s?)])(FoX::)?Image\s?\*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!^\\s)(?<=[\\((\\,\\s?)])(FoX::)?Image\\s?\\*', 'gm')
const str = `, Image *
,Image *
(Image *
( Image *
, FoX::Image *
,FoX::Image *
(FoX::Image *
( FoX::Image *
/* [retval][out] */ ICscImage **pVal) = 0;
 Image* pImage = Image::Create();
 Image* pImage = Image::Create();`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
    // This is necessary to avoid infinite loops with zero-width matches
    if (m.index === regex.lastIndex) {
        regex.lastIndex++;
    }
    
    // The result can be accessed through the `m`-variable.
    m.forEach((match, groupIndex) => {
        console.log(`Found match, group ${groupIndex}: ${match}`);
    });
}